How to debug a workflow?

2018-03-09 08:52:31

[Please bear with me, I am NOT an SP Admin, and have very little experience with SP]

I have a workflow that has been running effectively for a couple of years - but in the last 2 weeks it's suddenly "stopped" intermittently.

Tasks get created most of the time, but occasionally the task is not created.

Please could someone advise on how to debug/investigate what is happening?

I have heard there is a "workflow history" but don't know how to find it.

I have also looked at the Lists running workflows and it shows a small increasing number of items each morning before the Users are in the office - so I think something somewhere is stuck?

I had a similar issue, where a workflow appeared not to start when a list item was modified. It was due to a previous instance of the workflow being suspended. Here's how to identify this situation:

Select the list item by ticking its checkbox

In the Items tab, click Workflows. The button is disabled if more than one was selected

  • I had a similar issue, where a workflow appeared not to start when a list item was modified. It was due to a previous instance of the workflow being suspended. Here's how to identify this situation:

    Select the list item by ticking its checkbox

    In the Items tab, click Workflows. The button is disabled if more than one was selected

    Click the name of the suspended workflow (here, click OrderChanged)

    Click the little blue icon to show the error message causing the stall

    Finally, either end or resume the workflow

    2018-03-09 09:00:00